Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: Installing XTIVREG2 on Stata 9


From   Erasmo Giambona <e.giambona@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Installing XTIVREG2 on Stata 9
Date   Wed, 21 Jul 2010 03:31:49 +0200

Thanks all. When I type "update all" within Stata, I see that a lof of
files are downloaded, but I guess in the end they are not installed
because I keep getting an error message: r(603). Type version shows
that I still have version 9.0. I don't seem to be able to upgrade to
version 9.2. Any other suggestions would be appreciated.

Thanks,

Erasmo



search for r(603)

                                         (manual:  [R] search)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

        Keywords:  r(603)
          Search:  (1) Official help files, FAQs, Examples, SJs, and STBs


Search of official help files, FAQs, Examples, SJs, and STBs

[P]     error . . . . . . . . . . . . . . . . . . . . . . . .  Return code 603
        file __________ could not be opened;
        This file, although found, failed to open properly.  This
        error is unlikely to occur.  You will have to review your
        operating system's manual to determine why it occurred.

(end of search)



On Tue, Jul 20, 2010 at 1:08 PM, Christopher Baum <kit.baum@bc.edu> wrote:
> <>
> On Jul 20, 2010, at 2:33 AM, Erasmo wrote:
>
>> Dear All,
>>
>> I am trying to install XTIVREG2 on Stata 9, but I get the following
>> error message:
>>
>> this is version 9.0 of Stata; it cannot run version 10.1 programs
>>     You can purchase the latest version of Stata by visiting
>> http://www.stata.com.
>> Error - must have ivreg2/ivreg28/ivreg29 version 2.1.15 or greater installed
>>
>> I have previously installed ranktest and ivreg2 and this is the output
>> from "which"
>>
>> . which xtivreg2
>> c:\ado\plus\x\xtivreg2.ado
>> *! xtivreg2 1.0.12 17June2010
>> *! author mes
>>
>> . which ivreg2
>> c:\ado\plus\i\ivreg2.ado
>> *! ivreg2 3.0.05  17June2010
>> *! authors cfb & mes
>> *! see end of file for version comments
>>
>> . which ranktest
>> c:\ado\plus\r\ranktest.ado
>> *! ranktest 1.2.03  24Apr2010
>> *! author mes, based on code by fk
>>
>> Does anyone have any suggestions on what I could do to solve this issue?
>>
>> Thanks,
>>
>> Erasmo
>
>
> (1) upgrade Stata to version 9.2 (it's free).
> (2) ssc install ivreg29
> (3) ado uninstall ivreg2   (as you cannot run it under 9.2)
>
> and it should work.
>
> Kit
>
>
>
> Kit Baum   |   Boston College Economics & DIW Berlin   |   http://ideas.repec.org/e/pba1.html
>                              An Introduction to Stata Programming  |   http://www.stata-press.com/books/isp.html
>   An Introduction to Modern Econometrics Using Stata  |   http://www.stata-press.com/books/imeus.html
>
>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index