Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: RE: Problem with grqreg


From   "Nick Cox" <n.j.cox@durham.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: Problem with grqreg
Date   Wed, 5 May 2010 18:47:13 +0100

I tried this without problems:

clear
set obs 100
foreach v in y x1 x2 x3 x4 x5 x6 { 
	gen `v' = rnormal()
}
sqreg y x1-x6, quantile(.10 .20 .30 .40 .50 .60 .70 .80 .90) reps(400)

grqreg, cons ci ols olsci scale(1.1)

So, my only guess is that this is something to do with your data. 

Nick 
n.j.cox@durham.ac.uk 

Michael C. Morrison

First I run sqreg  with the following commands:

set seed 10101
sqreg dep_var  iv1 iv2  iv3 iv4 iv5 iv6, quantile(.10 .20 .30 .40 .50 
.60 .70 .80 .90) reps(400)

I want to use grqreg to plot the changes in the quantile slopes. I use 
the following command:

grqreg, cons ci ols olsci scale(1.1)

which should, I think, plot all 6 independent variables, plus intercept 
changes, with OLS and its ci added to each plot.

The problem is that the command only prints the intercept and the first 
two covariates (with OLS and its ci).

Thinking this was a limitation of available graph space I then tried to 
specify the next three covariates in the [varlist]:

grqreg  iv3 iv4 iv5, cons ci ols olsci scale(1.1)

Unfortunately I receive the same exact outcome as in the first grqreg 
command.


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index