Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: AW: RE: estimates use / estread problem


From   "Ben Jann" <ben.jann@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: AW: RE: estimates use / estread problem
Date   Wed, 17 Dec 2008 16:14:50 +0100

Are you saying that

 sysuse auto
 regress price weight
 estimates save myfile, replace
 ereturn clear
 estimates use myfile

does not work on your system? There must be something wrong with your
Stata installation.
ben


On Wed, Dec 17, 2008 at 3:55 PM, Jochen Späth <jochen.spaeth@iaw.edu> wrote:
> No, that's not the case, i.e. I'm not mixing up user-written and official Stata commands.
> Using --regress-- instead of --tobit-- produces the same error message.
>
> Any suggestions?
>
> Jochen
>
> -------------------------------------------------------------------------------------------
> Jochen Späth
> Dipl.-Volkswirt
> Institut für Angewandte Wirtschaftsforschung (IAW) Tübingen
> Ob dem Himmelreich 1
> 72074 Tübingen
> Tel.: +49-(0)7071-9896-14
> Fax: +49-(0)7071-9896-99
> EMail: jochen.spaeth@iaw.edu
> IAW-Homepage: www.iaw.edu
> -------------------------------------------------------------------------------------------
> -----Ursprüngliche Nachricht-----
> Von: owner-statalist@hsphsun2.harvard.edu [mailto:owner-statalist@hsphsun2.harvard.edu] Im Auftrag von Martin Weiss
> Gesendet: Mittwoch, 17. Dezember 2008 15:42
> An: statalist@hsphsun2.harvard.edu
> Betreff: st: RE: estimates use / estread problem
>
> Line for the server...
>
> What happens with a different model? Does it only happen if you mix the
> user-written commands with official Stata, i.e. -estwrite- when saving to
> disk, and -estimates use- when retrieving results?
>
> HTH
> Martin
>
>
> -----Original Message-----
> From: owner-statalist@hsphsun2.harvard.edu
> [mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of Jochen Späth
> Sent: Wednesday, December 17, 2008 3:31 PM
> To: statalist@hsphsun2.harvard.edu
> Subject: st: estimates use / estread problem
>
> Dear Statalisters,
>
> after running a tobit model on my data I would like to --estimates save-- or
> --estwrite-- the estimation results. So far, so good. However, when I try to
> --estimates use-- or --estread-- the estimation results I get an error
> message like this:
>
> "file not estimates"
>
> Or, in the case of --estread--:
>
> "file not estimates
> something is wrong; could not recover estimation set
>               _fclose():  3601  invalid file handle
>        estread_fclose():     -  function returned error
>                 <istmt>:     -  function returned error"
>
> Am I missing something? What is my mistake?
>
> Thank you very much,
> Jochen
>
>
> ----------------------------------------------------------------------------
> ---------------
> Jochen Späth
> Dipl.-Volkswirt
> Institut für Angewandte Wirtschaftsforschung (IAW) Tübingen
> Ob dem Himmelreich 1
> 72074 Tübingen
> Tel.: +49-(0)7071-9896-14
> Fax: +49-(0)7071-9896-99
> EMail: jochen.spaeth@iaw.edu
> IAW-Homepage: www.iaw.edu
> ----------------------------------------------------------------------------
> ---------------
>
>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>
>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index