Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

RE: st: STATA: multivariate probit w/ bootstrap


From   "David Roodman (DRoodman@cgdev.org)" <DRoodman@CGDEV.ORG>
To   <statalist@hsphsun2.harvard.edu>
Subject   RE: st: STATA: multivariate probit w/ bootstrap
Date   Thu, 1 May 2008 09:21:52 -0400

--- "Daniel R. Petrolia" <Petrolia@agecon.msstate.edu> wrote:
>   I am trying to bootstrap using either 'mvprobit' or 'triprobit',
> but have been unsuccessful with both.  Using 'mvprobit', the
> bootstrap "works" (i.e., there are no errors reported), but it is
> reporting and saving identical coefficients for each bootstrapped
> sample (which implies that it is running mvprobit over the same
> sample).  When I use 'triprobit', the bootstrap returns the error
> message "too few variables specified", although it does indeed run
> the bootstrap for the requested number of reps; however, it reports
> one set of coefficients on the first sample, then a different set of
> coefficients on the second and all subsequent samples. 

Possibly the -cmp- command will help, and run a bit faster to boot. It does *not* reset the seed. Whether the others do, I don't know. I haven't tested it vigorously with bootstrap, so I'd be interested if you find problems.


David Roodman
Research Fellow
1776 Massachusetts Avenue NW
Washington, DC 20036
Center for Global Development
Independent Research and Practical Ideas for Global Prosperity
 
Phone: 1 202 416-0723



*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index