Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: ivreg2: difference in first regression results


From   "Nick Cox" <n.j.cox@durham.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: ivreg2: difference in first regression results
Date   Tue, 22 Apr 2008 15:38:57 +0100

I suggest that you report the results of 

. which ivreg2 

in both cases, as "at home" and "in my office" do not convey that
information. 

Nick
n.j.cox@durham.ac.uk 

bmilanovic@worldbank.org

I noticed that my ivreg2.ado for Stata8 which I use at home produces
different
results (in the first regression: F test of excluded instruments etc.)
than my
ivreg2.ado which I use in my office with Stata9. The results are shown
below.

The second equation is exactly the same, but in the first  t values and
the F
statistic are very different.  The whole thing is run with cluster and
robust
controls which I thought were identical in both cases. But they
obviously are
not. So am I doing something wrong?
(The more recent version of ivreg2 seems to use degrees of freedom based
on
clusters, not on the number of observations which seems to be the reason
why F
critical values in the first regression differ between the two
versions.)

Any ideas why this is the case and which one of the version is
"correct"?


*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index