Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: RE: problem with stattransfer within Stata


From   "Newson, Roger B" <r.newson@imperial.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: RE: problem with stattransfer within Stata
Date   Wed, 16 Apr 2008 18:58:27 +0100

I am assuming that -inputst- is my program (the -inputst- program of the
-stcmd- package). In that case, inputst is not saying "file not found"
because it couldn't find the file
"C:\statawrk\MAPMISS/MRecord-I-080907.txt"
It is saying "file not found" because it attempted to run Stat/Transfer
to input
"C:\statawrk\MAPMISS/MRecord-I-080907.txt"
and create a temporary file (containing a Stata dataset) as output, and
Stat/Transfer failed to create this temporary file, so this temporary
file is the file that was "not found". (See -whelp tempfile- for more on
temporary files.) The problem is therefore probably in Stat/Transfer,
not in Stata.

I do not know how large your file
"C:\statawrk\MAPMISS/MRecord-I-080907.txt"
is, or whether there are security issues with it. However, I have the
very latest update of Stat/Transfer Version 9. If it is possible for you
to send me a copy of your file
"C:\statawrk\MAPMISS/MRecord-I-080907.txt"
then I can attempt to find out the problem that Stat/Transfer is having.

Best wishes

Roger


Roger B Newson
Lecturer in Medical Statistics
Respiratory Epidemiology and Public Health Group
National Heart and Lung Institute
Imperial College London
Royal Brompton campus
Room 33, Emmanuel Kaye Building
1B Manresa Road
London SW3 6LR
UNITED KINGDOM
Tel: +44 (0)20 7352 8121 ext 3381
Fax: +44 (0)20 7351 8322
Email: r.newson@imperial.ac.uk 
Web page: www.imperial.ac.uk/nhli/r.newson/
Departmental Web page:
http://www1.imperial.ac.uk/medicine/about/divisions/nhli/respiration/pop
genetics/reph/

Opinions expressed are those of the author, not of the institution.

-----Original Message-----
From: owner-statalist@hsphsun2.harvard.edu
[mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of Nick Cox
Sent: 16 April 2008 18:39
To: statalist@hsphsun2.harvard.edu
Subject: st: RE: problem with stattransfer within Stata

You say you wrote a program. 

If -inputst- is your program, then we cannot debug it without seeing the
code. 

Alternatively, if -inputst- is the program written by Roger Newson, my
guess is that he would
need to work with your data file to make progress on this. I suggest
that you send it 
to him privately. 

Nick
n.j.cox@durham.ac.uk 

Ricardo Ovaldia

I wrote a program last year which I use to import data
into Stata using Stat-Transfer. The program worked and
it worked in February (last time it was ran). Now it
does no work, and as far as I can tell nothing jas
changed expect Stata updates (ado and executable)

The code reads:

 . inputst "C:\statawrk\MAPMISS/MRecord-I-080907.txt"
Stat/Transfer did not run successfully
file not found
r(601);

the file does exist:

. dir  "C:\statawrk\MAPMISS/MRecord-I-080907.txt"
  19.8k   4/16/08 12:08  MRecord-I-080907.txt
r(601);


*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index