Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Is there a bug in stata 9


From   "Li Chuntao" <chtl@hkusua.hku.hk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: Is there a bug in stata 9
Date   Wed, 26 Sep 2007 02:24:55 +0800

Dear Users,

refer to my previous emails, i find that the dtobit can be used in Stata 8, but cannot be used in Stata 9.0. i am not using stata 10 till now. Can you please also check your system if dtobit works?

thanks

Li Chuntao


----- Original Message ----- From: "Li Chuntao" <chtl@hkusua.hku.hk>
To: <statalist@hsphsun2.harvard.edu>
Sent: Wednesday, September 26, 2007 2:11 AM
Subject: Dtobit after tobit



Dear Users,

recall my previous mail, i find that, actually dtobit does not work in Stata 9. I do not know if this command works in your system.

following is my output:

. sysuse auto, clear
. tobit mpg trunk weight, ll(17)

Tobit regression Number of obs = 74
LR chi2(2) = 73.86
Prob > chi2 = 0.0000
Log likelihood = -163.74787 Pseudo R2 = 0.1840

------------------------------------------------------------------------------
mpg | Coef. Std. Err. t P>|t| [95% Conf. Interval]
-------------+----------------------------------------------------------------
trunk | -.1487203 .1477163 -1.01 0.317 -.4431875 .1457468
weight | -.0063328 .0008709 -7.27 000 -.008069 -.0045966
_cons | 41.90603 2.094632 20.01 0.000 37.73045 46.0816
-------------+----------------------------------------------------------------
/sigma | 3.822488 .3637359 3.097394 4.547582
------------------------------------------------------------------------------
Obs. summary: 18 left-censored observations at mpg<=17
56 uncensored observations
0 right-censored observations

. dtobit
[_se] not found
r(111);


can you please give me a feedback?

thanks

Chuntao

----- Original Message ----- From: "Li Chuntao" <chtl@hkusua.hku.hk>
To: <statalist@hsphsun2.harvard.edu>
Sent: Wednesday, September 26, 2007 1:41 AM
Subject: outreg after tobit model



Dear Users,

i am currently using stata 9.0. after i estimate a tobit regression model, i use dtobit2 to estimate the marginal effect. my question is, how to report the marginal effect coefficient by using outreg.

in the manual, i find that there is a why to report it if i use dtobit after tobit, my problem is that, dtobit is not longer applicable. it simply does not work after my tobit

following is the output

sysuse auto, clear
tobit mpg trunk weight, ll(17)

Tobit regression Number of obs = 74
LR chi2(2) = 73.86
Prob > chi2 = 0.0000
Log likelihood = -163.74787 Pseudo R2 = 0.1840

------------------------------------------------------------------------------
mpg | Coef. Std. Err. t P>|t| [95% Conf. Interval]
-------------+----------------------------------------------------------------
trunk | -.1487203 .1477163 -1.01 0.317 -.4431875 .1457468
weight | -.0063328 .0008709 -7.27 000 -.008069 -.0045966
_cons | 41.90603 2.094632 20.01 0.000 37.73045 46.0816
-------------+----------------------------------------------------------------
/sigma | 3.822488 .3637359 3.097394 4.547582
------------------------------------------------------------------------------
Obs. summary: 18 left-censored observations at mpg<=17
56 uncensored observations
0 right-censored observations

. dtobit
[_se] not found
r(111);


Can someone help me out?

thanks

Li Chuntao



*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index