Statalist The Stata Listserver


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Problem with stsplit and survey data that isn't


From   "Richard Atkins" <Richard.Atkins@lshtm.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: Problem with stsplit and survey data that isn't
Date   Tue, 24 Oct 2006 12:40:17 +0100

Hi all,

I've solved my problem but I don't know why and I'd like to understand
better.

I was trying to use the stsplit command on a set of data and getting an
error message "stsplit not allowed with survey data".  
I checked and my do file did not contain any svy... commands. I also
checked that my data had no underscore prefixed variables from any prior
svy commands that may have been used historically so I couldn't see why
stata thought this data had been identified as survey data.  Next step
was to save the dataset and then try again with a minimal command set of
clear, use, stset and then stsplit.  Still the same error.  Finally I
'keep'ed just the four variables required for these commands (ageentry,
ageexit, dead, id) and tried again and it worked.

It appears that something stored in or attached to one of the dropped
variables identified this data as survey data. This particular dataset
contains about 400 variables so I am reluctant to use trial and error to
identify the culprit, so can anyone tell me what might cause this?

Thanks

Richard Atkins
London School of Hygiene and Tropical Medicine
www.lshtm.ac.uk and www.richardatkins.co.uk 


*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index