Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Problem with xtmixed after gam (was:xtmixed broken in Stata 9.1?)


From   "Dr. Stephen Rothenberg" <srothenberg@mda.cinvestav.mx>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: Problem with xtmixed after gam (was:xtmixed broken in Stata 9.1?)
Date   Wed, 21 Sep 2005 15:34:42 -0500

The problem was solved by exiting Stata, shutting down the machine, booting up cold and re-running the commands.

Previous to the xtmixed problems I had been running a set of -gam- models on another data set.

After successfully running -xtmixed- on a clean machine and unused Stata session, I then tried a -gam- analysis and went back to -xtmixed-. The problem re-appeared.

Apparently -gam- now does something bad to Stata 9.1, leaving it in a state from which it cannot use what -xtmixed requires. Perhaps its call to a FORTRAN program is what screws up the subsequent -xtmixed-. The problem doesn't occur after -gam- when I run the "pig" data set with regress nor when I try -xtreg, mle-, but I don't have time to exhaustively test all the -xt- commands

Does anyone know if Patrick Royston or Gareth Ambler, the authors of -gam-, are still members of statalist?

Thanks for clueing me that it was something I had done, Nick, and not general to Stata 9.1.

Best,
Steve

----- Original Message ----- From: "Nick Cox" <n.j.cox@durham.ac.uk>
To: <statalist@hsphsun2.harvard.edu>
Sent: Wednesday, September 21, 2005 3:08 PM
Subject: st: RE: Re: RE: xtmixed broken in Stata 9.1?



That clearly looks OK. The explanation
must therefore lie elsewhere, but I've
run out of ideas.

Nick
n.j.cox@durham.ac.uk

Dr. Stephen Rothenberg

Here is my update status:

--------------------------------------------------------------
-------------------
update query
--------------------------------------------------------------
-------------------
(contacting http://www.stata.com)

Stata executable
    folder:               C:\Program Files\Stata9\
    name of file:         wsestata.exe
    currently installed:  15 Sep 2005
    latest available:     15 Sep 2005

Ado-file updates
    folder:               C:\Program Files\Stata9\ado\updates\
    names of files:       (various)
    currently installed:  19 Sep 2005
    latest available:     19 Sep 2005

Recommendation
    Do nothing; all files up to date.

Click to edit automatic update checking preferences
--------------------------------------------------------------
Nick Cox

> This works for me.
>
> Perhaps you updated your executable, but not
> the other files.
Dr. Stephen Rothenberg

>> I'm trying to run -xtmixed- in Stata 9.1 SE, Windows XP,
>> after successfully using it in Stata 9.0.
>>
>> I keep getting the same error message no matter what my model
>> specs are (see
>> below).  Finally I tried copying Example 1 from the -xtmixed-
>> section of the
>> panel data manual.
>>
>> I downloaded the "pig" data set used in the example and tried
>> the code
>> listed there:
>>
>>     . use http://www.stata-press.com/data/r9/pig
>>     (Longitudinal analysis of pig weights)
>>
>>     . xtmixed weight week || id:
>>     last estimates not found
>>     r(301);
>>
>> The "not found" error message is the same problem when I use
>> my own data
>> set.
>>
>> Am I doing something dumb or is -xtmixed- broked in Stata 9.1?
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index