Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: Problems with Stata 8


From   "Nick Cox" <n.j.cox@durham.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: Problems with Stata 8
Date   Thu, 31 Jul 2003 12:31:39 +0100

Jose Ernesto Lopez-Cordova
 
> I recently switched to Stata 8 and I4m experiencing
> the following problems:
> 
> (1) I am trying to read data originally in a MS Excel
> file into Stata. After reading the data one of my
> variables has all missing observations. I have tried
> these alternatives: copying and pasting into the data
> editor; transforming into CSV or tab-separated TXT
> files and then using the insheet command; formating
> the variable in Excel as a string and as a numeric
> value and reading it into Stata.
> 
> What puzzles me the most is that these different
> alternatives work just fine when I implement them in
> Stata 7, which I still have in my PC.
> 
> Did the <insheet> command change (incidentally, in
> Stata 8, I also set the version to 7 and then use the
> insheet command; no success either)?

Typing 

. help whatsnew7to8 

tells you 

15.  Existing command insheet has a new delimiter(char) 
option that allows you to specify an arbitrary character 
as the value separator; see help insheet.

Moreover, in 8.1, 

12.  insheet did not honor the double option; this is fixed.

There are various suggestions in 
http://www.stata.com/support/faqs/data/newexcel.html

> (2) I tried using the xtile command and get an
> "invalid syntax" error. This problem doesn't occur
> when I use Stata 7. As a check, using again Stata 8, I
> used the dataset suggeted in the reference manuals and
> followed exactly what the manual does. I still get an
> error message.

Going to [R] pctile, p.146, I typed 

use http://www.stata-press.com/data/r8/bp1, clear
list bp, sep(4)
xtile quart = bp, nq(4)
list bp quart, sep(4)

and got the results there claimed. So I cannot 
reproduce what you report. 

Nick 
n.j.cox@durham.ac.uk 

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index