1 8 Learning more about Stata

Where to go from here

You now know plenty enough to use Stata. There is still much, much more to learn because Stata is a
rich environment for doing statistical analysis and data management. What should you do to learn more?
e Get an interesting dataset and play with Stata.

a. Use the menus and dialog system to experiment with commands. Notice what commands
show up in the Results window. You will find that Stata’s simple and consistent command
syntax will make the commands easy to read so that you will know what you have done and
easy to remember so that typing some commands will be faster than using menus.

b. Play with graphs and the Graph Editor.

e If you venture into the Command window, you will find that many things will go faster. You will
also find that it is possible to make mistakes where you cannot understand why Stata is balking.
a. Try help commandname or Help > Stata command... and entering the command name.
b. Look at the command syntax and the examples in the help file, and compare them with what
you typed. Compare them closely: small typographical errors make commands impossible
for Stata to parse.

e Explore Stata by selecting Help > Search.... You will uncover many statistical routines that could
be of great use.

e Look through the Combined subject table of contents in the Stata Index.

e Read and work your way through the User’s Guide. It is designed to be read from cover to cover,
and it contains most of the information you need to become an expert Stata user. It is well worth
reading. If you are not this ambitious and instead prefer to sample the User’s Guide and the refer-
ences, there is some advice later in this chapter for you.

e Browse through the reference manuals to read about statistical methods you like to use, making
use of the links to jump to other topics. The reference manuals are not meant to be read from cover
to cover—they are meant to be referred to as you would an encyclopedia. You can find the datasets
used in the examples in the manuals by selecting File > Example datasets... and then clicking on
Stata 19 manual datasets. Doing so will enable you to work through the examples quickly.

e Stata has much information, including answers to frequently asked questions (FAQs), at https://www.stata
port/faqs/.

e There are many useful links to Stata resources at https://www.stata.com/links/. Be sure to look at
these materials because many outstanding resources about Stata are listed here.

e Join Statalist, a forum devoted to discussion of Stata and statistics.

e Read The Stata Blog: Not Elsewhere Classified at https://blog.stata.com to read articles written by
people at Stata about all things Stata.

e Visit Stata on Facebook at https://facebook.com/statacorp/,
join Stata on Instagram at https://www.instagram.com/statacorp/,
find Stata on LinkedIn at https://www.linkedin.com/company/statacorp/,
and follow Stata on X at https://x.com/stata/ to keep up with Stata.

e Subscribe to the Stata Journal, which contains reviewed papers, regular columns, book reviews,
and other material of interest to researchers applying statistics in a variety of disciplines. Visit
https://www.stata-journal.com.


https://www.stata.com/manuals/icombinedsubjecttableofcontents.pdf#iCombinedsubjecttableofcontents
https://www.stata.com/manuals/uuusersguide.pdf#uuUsersGuide
https://www.stata.com/support/faqs/
https://www.stata.com/support/faqs/
https://www.stata.com/links/
https://www.statalist.org
https://blog.stata.com
https://facebook.com/statacorp/
https://www.instagram.com/statacorp/
https://www.linkedin.com/company/statacorp/
https://x.com/stata/
https://www.stata-journal.com
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e Many supplementary books about Stata are available. Visit the Stata Bookstore at
https://www.stata.com/bookstore/.

e Take a Stata NetCourse®. NetCourse 101 is an excellent choice for learning about Stata. See
https://www.stata.com/netcourse/ for course information and schedules.

e Attend a classroom or a web-based training course taught by StataCorp. Visit
https://www.stata.com/training/classroom-and-web/ for course information and schedules.

e View a webinar led by StataCorp. Visit https://www.stata.com/training/webinar/ for the current
list of topics and schedule.

e Watch Stata videos at https://www.youtube.com/user/statacorp/.

Suggested reading from the User’s Guide and reference manuals

The User’s Guide is designed to be read from cover to cover. The reference manuals are designed as
references to be sampled when necessary.

Ideally, after reading this Getting Started manual, you should read the User’s Guide from cover to
cover, but you probably want to become at least somewhat proficient in Stata right away. Here is a
suggested reading list of sections from the User’s Guide and the reference manuals to help you on your
way to becoming a Stata expert.

This list covers fundamental features and points you to some less obvious features that you might
otherwise overlook.
Basic elements of Stata
[U] 11 Language syntax
[U] 12 Data
[U] 13 Functions and expressions

Data management
[U] 6 Managing memory
[U] 22 Entering and importing data
[D] import — Overview of importing data into Stata
[D] append — Append datasets
[D] merge — Merge datasets
[D] compress — Compress data in memory
[D] frames intro — Introduction to frames
Graphics
[G] Stata Graphics Reference Manual
Reproducible research
[U] 16 Do-files
[U] 17 Ado-files
[U] 13.5 Accessing coefficients and standard errors
[U] 13.6 Accessing results from Stata commands
[U] 21 Creating reports
[RPT] Dynamic documents intro — Introduction to dynamic documents
[RPT] putdocx intro — Introduction to generating Office Open XML (.docx) files
[RPT] putexcel — Export results to an Excel file


https://www.stata.com/bookstore/
https://www.stata.com/netcourse/
https://www.stata.com/training/classroom-and-web/
https://www.stata.com/training/webinar/
https://www.youtube.com/user/statacorp/
https://www.stata.com/manuals/u11.pdf#u11Languagesyntax
https://www.stata.com/manuals/u12.pdf#u12Data
https://www.stata.com/manuals/u13.pdf#u13Functionsandexpressions
https://www.stata.com/manuals/u6.pdf#u6Managingmemory
https://www.stata.com/manuals/u22.pdf#u22Enteringandimportingdata
https://www.stata.com/manuals/dimport.pdf#dimport
https://www.stata.com/manuals/dappend.pdf#dappend
https://www.stata.com/manuals/dmerge.pdf#dmerge
https://www.stata.com/manuals/dcompress.pdf#dcompress
https://www.stata.com/manuals/dframesintro.pdf#dframesintro
https://www.stata.com/manuals/g-1ggraphics.pdf#g-1gGraphics
https://www.stata.com/manuals/u16.pdf#u16Do-files
https://www.stata.com/manuals/u17.pdf#u17Ado-files
https://www.stata.com/manuals/u13.pdf#u13.5Accessingcoefficientsandstandarderrors
https://www.stata.com/manuals/u13.pdf#u13.6AccessingresultsfromStatacommands
https://www.stata.com/manuals/u21.pdf#u21Creatingreports
https://www.stata.com/manuals/rptdynamicdocumentsintro.pdf#rptDynamicdocumentsintro
https://www.stata.com/manuals/rptputdocxintro.pdf#rptputdocxintro
https://www.stata.com/manuals/rptputexcel.pdf#rptputexcel
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[RPT] putpdf intro — Introduction to generating PDF files
[R] log — Echo copy of session to file

Useful features that you might overlook
[U] 29 Using the internet to keep up to date
[U] 19 Immediate commands
[U] 24 Working with strings
[U] 25 Working with dates and times
[U] 26 Working with categorical data and factor variables
[U] 27 Overview of Stata estimation commands
[U] 20 Estimation and postestimation commands
[R] estimates — Save and manipulate estimation results

Basic statistics
[R] anova — Analysis of variance and covariance
[R] ci — Confidence intervals for means, proportions, and variances
[R] correlate — Correlations of variables
[D] egen — Extensions to generate
[R] regress — Linear regression
[R] predict — Obtain predictions, residuals, etc., after estimation
[R] regress postestimation — Postestimation tools for regress
[R] test — Test linear hypotheses after estimation
[R] summarize — Summary statistics
[R] table intro — Introduction to tables of frequencies, summaries, and command results
[R] tabulate oneway — One-way table of frequencies
[R] tabulate twoway — Two-way table of frequencies
[R] ttest — ¢ tests (mean-comparison tests)

Matrices
[U] 14 Matrix expressions
[U] 18.5 Scalars and matrices
[M] Mata Reference Manual

Programming
[U] 16 Do-files
[U] 17 Ado-files
[U] 18 Programming Stata
[R] ml — Maximum likelihood estimation
[P] Stata Programming Reference Manual
[M] Mata Reference Manual

System values
[R] set — Overview of system parameters
[P] creturn — Return c-class values


https://www.stata.com/manuals/rptputpdfintro.pdf#rptputpdfintro
https://www.stata.com/manuals/rlog.pdf#rlog
https://www.stata.com/manuals/u29.pdf#u29Usingtheinternettokeepuptodate
https://www.stata.com/manuals/u19.pdf#u19Immediatecommands
https://www.stata.com/manuals/u24.pdf#u24Workingwithstrings
https://www.stata.com/manuals/u25.pdf#u25Workingwithdatesandtimes
https://www.stata.com/manuals/u26.pdf#u26Workingwithcategoricaldataandfactorvariables
https://www.stata.com/manuals/u27.pdf#u27OverviewofStataestimationcommands
https://www.stata.com/manuals/u20.pdf#u20Estimationandpostestimationcommands
https://www.stata.com/manuals/restimates.pdf#restimates
https://www.stata.com/manuals/ranova.pdf#ranova
https://www.stata.com/manuals/rci.pdf#rci
https://www.stata.com/manuals/rcorrelate.pdf#rcorrelate
https://www.stata.com/manuals/degen.pdf#degen
https://www.stata.com/manuals/rregress.pdf#rregress
https://www.stata.com/manuals/rpredict.pdf#rpredict
https://www.stata.com/manuals/rregresspostestimation.pdf#rregresspostestimation
https://www.stata.com/manuals/rtest.pdf#rtest
https://www.stata.com/manuals/rsummarize.pdf#rsummarize
https://www.stata.com/manuals/rtableintro.pdf#rtableintro
https://www.stata.com/manuals/rtabulateoneway.pdf#rtabulateoneway
https://www.stata.com/manuals/rtabulatetwoway.pdf#rtabulatetwoway
https://www.stata.com/manuals/rttest.pdf#rttest
https://www.stata.com/manuals/u14.pdf#u14Matrixexpressions
https://www.stata.com/manuals/u18.pdf#u18.5Scalarsandmatrices
https://www.stata.com/manuals/m-0mmata.pdf#m-0mMata
https://www.stata.com/manuals/u16.pdf#u16Do-files
https://www.stata.com/manuals/u17.pdf#u17Ado-files
https://www.stata.com/manuals/u18.pdf#u18ProgrammingStata
https://www.stata.com/manuals/rml.pdf#rml
https://www.stata.com/manuals/ppprogramming.pdf#ppProgramming
https://www.stata.com/manuals/m-0mmata.pdf#m-0mMata
https://www.stata.com/manuals/rset.pdf#rset
https://www.stata.com/manuals/pcreturn.pdf#pcreturn
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Internet resources

The Stata website (https://www.stata.com) is a good place to get more information about Stata. You
will find answers to FAQs, ways to interact with other users, official Stata updates, and other useful
information. You can also join Statalist, a forum devoted to discussion of Stata and statistics.

You will also find information on Stata NetCourses®, which are interactive courses offered over the
internet that vary in length from a few weeks to eight weeks. Stata also offers in-person and web-based
training sessions, as well as webinars on Stata features. Visit https://www.stata.com/learn/ for more
information.

At the website is the Stata Bookstore, which contains books that we feel may be of interest to Stata
users. Each book has a brief description written by a member of our technical staff explaining why we
think this book may be of interest.

We suggest that you take a quick look at the Stata website now. You can register your copy of Stata
online and request a free subscription to the Stata News.

Visit https://www.stata-press.com for information on books, manuals, and journals published by Stata
Press. The datasets used in examples in the Stata manuals are available from the Stata Press website.

Also visit https://www.stata-journal.com to read about the Stata Journal, a quarterly publication con-
taining articles about statistics, data analysis, teaching methods, and effective use of Stata’s language.

Visit Stata’s official blog at https://blog.stata.com for news and advice related to the use of Stata. The
articles appearing in the blog are individually signed and are written by the same people who develop,
support, and sell Stata. The Stata Blog: Not Elsewhere Classified also has links to other blogs about
Stata, written by Stata users around the world.

Follow Stata on Facebook at https://facebook.com/statacorp/, X at https://x.com/stata/, Instagram at
https://www.instagram.com/statacorp/, and LinkedIn at https://www.linkedin.com/company/statacorp/.
You may also follow Stata on X at https://x.com/stata_fr/ or https://x.com/stata_es/. These are good
ways to stay up-to-the-minute with the latest Stata information. Watch short example videos of using
Stata on YouTube at https://www.youtube.com/user/statacorp/.

See [GSM] 19 Updating and extending Stata—internet functionality for details on accessing offi-
cial Stata updates and free additions to Stata on the Stata website.


https://www.stata.com
https://www.stata.com/learn
https://www.stata.com/register/
https://www.stata.com/customer-service/stata-news/
https://www.stata-press.com
https://www.stata-journal.com
https://blog.stata.com
https://facebook.com/statacorp/
https://x.com/stata/
https://www.instagram.com/statacorp/
https://www.linkedin.com/company/statacorp/
https://x.com/stata_fr/
https://x.com/stata_es/
https://www.youtube.com/user/statacorp/
https://www.stata.com/manuals/gsm19.pdf#gsm19UpdatingandextendingStata---internetfunctionality
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Stata, Stata Press, Mata, NetCourse, and NetCourseNow are registered trademarks of StataCorp

LLC. Stata and Stata Press are registered trademarks with the World Intellectual Property Or- {t\e,.\ ©
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For suggested citations, see the FAQ on citing Stata documentation.


https://www.stata.com/support/faqs/resources/citing-software-documentation-faqs/

