Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: hunting for the source of an error - r(603) - Dual Core problem?


From   "Ben Hoen" <bhoen@lbl.gov>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: hunting for the source of an error - r(603) - Dual Core problem?
Date   Thu, 27 Dec 2012 08:43:20 -0500

Hi all,

I have a relatively simple looping function that repeatedly saves and calls
up temp files while looping through each case in a dataset, which, if
successful, should take ~ 8 hours to run, though, I have yet to have it
execute properly.  The last four times I have tried to run it will the full
sample I have gotten the same error:

"file C:\Users\Ben\AppData\Local\Temp\ST_0500000x.tmp could not be opened
r(603);

end of do-file

r(603);"

where x=3, 4 or 6 

Each time the error has happened on a different case.  The most recent three
occurred on the 794th, 25,835th and the 20,633rd  cases (and before that I
had runs out to the 70,000 and 60,000th (or so) cases.  There are a total of
166,181 cases. 

Is it something outside my code that is likely making this occur?  I am
wondering if this has something to do with a dual-core processor.  I am
running Windows 7- 64bit, with an Intel Duo Core E8600 - 3.33 Ghz processor
with 8 GB of RAM, and am running Stata MP 12.1 for Windows - 64bit.  BUT,
that is a GUESS (and nothing more).  My thought was that this error is
occurring when the file is in use or is stored in one processor while the
other is trying to access it?  

I have tried to force the error by running the code using many different
subsamples and have never been able to get it to crash, and unfortunately
breaking the sample down into smaller sample somewhat defeats the purpose of
the code in the first place (which is creating nearest neighbor weights -
using, in part, geonear(SSC)).  It seems important that the error has
occurred on a different case, potentially indicating that the problem is not
with the sample.  

Any ideas?  Thank you in advance for any assistance/advice you can offer.

Ben

Ben Hoen
Principal Research Associate
Lawrence Berkeley National Laboratory
Office: 845-758-1896
Cell: 718-812-7589
bhoen@lbl.gov
http://emp.lbl.gov/staff/ben-hoen

Visit our publications at: 
http://emp.lbl.gov/publications





*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/faqs/resources/statalist-faq/
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index