Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, is already up and running.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: option noomit not allowed

From   Nick Cox <>
Subject   Re: st: option noomit not allowed
Date   Tue, 11 Sep 2012 18:27:14 +0100

Works for me. I suspect an incomplete -update-. Problems can arise if
you have (e.g.) updated the executable, but not all associated files.


. update query

and look carefully to see whether you have installed all available updates.


On Tue, Sep 11, 2012 at 6:18 PM, Donald Spady <> wrote:

> I just tried to run a logistic regression and got the response "option noomit not allowed"
> I had done the exact same regression on the same dataset a while back and got some results; today not so.
> So I tried it using
> sysuse auto.dta
> logistic foreign mpg,
> where foreign is a 0/1 variable that mpg is continuous.
> and I got the response
> "option noomit not allowed"
> I tried it with xi: as in
> xi: logistic foreign i.rep78 and got
> . xi: logistic foreign i.rep78
> i.rep78           _Irep78_1-5         (naturally coded; _Irep78_1 omitted)
> note: _Irep78_2 != 0 predicts failure perfectly
>       _Irep78_2 dropped and 8 obs not used
> option noomit not allowed
> r(198);
> HELP.  What is going on.
*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index