Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: r451 error when using nl command and hac std error


From   Nick Cox <njcoxstata@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: r451 error when using nl command and hac std error
Date   Mon, 16 Jul 2012 22:38:20 +0100

There are no details here on what "panel data model" you are fitting
and no statement of your precise syntax. My wild guess, however, is
that you seem to be presuming that -nl- treats, or should treat, your
panels separately, whereas it is lumping panels together. So from its
perspective there _are_ repeated time values. Similarly, my guess is
that you can apply this option if and only if you fit your model to a
single panel.

Nick

On Mon, Jul 16, 2012 at 10:21 PM, William (Billy) Hankins
<wbhankins@crimson.ua.edu> wrote:
> I am estimating a panel data model using the nl command and I am
> attempting to estimate the model with different standard error
> specifications (gnr, hc3, hac nw)  so that I can compare the standard
> errors.  When I estimate the model and specify gnr or hc3 I obtain
> convergence.  However, when I use vce(hac nw) I receive an r(451)
> error.  I have performed several checks that verify that I do not have
> duplicate or repeated time values so I am confused as to why this
> error presents itself when using the vce(hac nw) option.  Any help is
> greatly appreciated.
>
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index