Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: -more- within a do file not working


From   A Loumiotis <antonis.loumiotis@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: -more- within a do file not working
Date   Mon, 30 Apr 2012 10:19:00 +0300

I opened a new Stata session and now -more- works as expected even
within a do file.  Only for the particular Stata session that I was
working with yesterday -more- did not cause Stata to pause.  I'm not
sure why.

Thanks for your help.
Antonis

On Sun, Apr 29, 2012 at 11:19 PM, Nick Cox <njcoxstata@gmail.com> wrote:
> We went through this only a few days ago. See e.g.
>
> http://www.stata.com/statalist/archive/2012-04/msg00858.html
>
> In short. -set more- is a local action.
>
> On Sun, Apr 29, 2012 at 5:56 PM, A Loumiotis
> <antonis.loumiotis@gmail.com> wrote:
>> Hi,
>>
>> I'm having trouble with the -more- command.
>>
>> When I type in the command window:
>>
>> set more on
>> more
>>
>> Stata as expected displays --more-- and pauses until any key is pressed.
>>
>> But, if I place the above commands in a do file and execute it, Stata
>> does not display --more-- and there is no pause.
>>
>> I use Stata/MP 11.2 on Windows XP.
>>
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index