Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: Different results using xtabond2 on 32-bit and 64-bit Windows 7 machines (I'm away)


From   <Rhian.Daniel@lshtm.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   RE: st: Different results using xtabond2 on 32-bit and 64-bit Windows 7 machines (I'm away)
Date   Sun, 11 Dec 2011 18:40:26 +0000

Thank you for your message. However, I am currently on annual leave, returning to work on Monday 19th December. I will reply to your message then.
Best wishes,
Rhian

>>> <Rhian.Daniel@lshtm.ac.uk> 12/11/11 18:34 >>>

Thank you for your message. However, I am currently on annual leave, returning to work on Monday 19th December. I will reply to your message then.
Best wishes,
Rhian

>>> "Kate Ivanova" <kivstata@gmail.com> 12/11/11 18:27 >>>

Thanks, Richard, but I do have the latest version on both machines, that is,
xtabond2 2.9.4 23 May 2011 so that does not seem to drive the difference in
the results.

Any other suggestions would be greatly appreciated.

Kate



-----Original Message-----
From: owner-statalist@hsphsun2.harvard.edu
[mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of Richard Williams
Sent: Sunday, December 11, 2011 1:54 AM
To: statalist@hsphsun2.harvard.edu
Subject: Re: st: Different results using xtabond2 on 32-bit and 64-bit
Windows 7 machines

At 12:41 AM 12/11/2011, Kate Ivanova wrote:
>Hi Statalist Users,
>
>I am puzzled by the fact that I get different results using exactly the 
>same command on two different machines: one has a 32-bit Windows 7 and 
>the other one has a 64-bit Windows 7.
>
>The command is as follows:
>xi: xtabond2 depvar l.depvar x1 x2 x3 i.Year, gmm(l.depvar, lag(1 1)) 
>iv(x1
>x2 x3 i.Year, eq(diff)) robust h(2) orthogonal nolevel twostep
>
>It seems the difference in the results comes from the fact that Stata 
>uses a different number of observations on the two machines: 1281 obs 
>(114 groups) on the machine with 32-bit version and 1248 obs (113 
>groups) on the machine with 64-bit version while the data I am using 
>are exactly the same on both machines.

I think the first thing I would do is make sure I have the same version of
xtabond2 on both machines. On mine I get

. which xtabond2
c:\ado\plus\x\xtabond2.ado
*! xtabond2 2.9.4 23 May 2011
*! David Roodman, Center for Global Development, Washington, DC,
www.cgdev.org *! Copyright David Roodman 2004-11. May be distributed free.



-------------------------------------------
Richard Williams, Notre Dame Dept of Sociology
OFFICE: (574)631-6668, (574)631-6463
HOME:   (574)289-5227
EMAIL:  Richard.A.Williams.5@ND.Edu
WWW:    http://www.nd.edu/~rwilliam

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index