Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

re:st:re: xtabond2 error


From   CF Baum <kitbaum@mac.com>
To   statalist@hsphsun2.harvard.edu
Subject   re:st:re: xtabond2 error
Date   Fri, 02 Dec 2011 15:44:55 -0500

<>
Thanks a lot for your help. I am in fact using the lag suboption and still getting the error. Here is my command:

xtabond2 mmisspay l.mmisspay week week2 pastmisswk pastmissgrpwk ageweek-hhstructweek nmembersweek age_grpweek-hhstruct_grpweek if sex==1,  gmm(mmisspay pastmisswk pastmissgrpwk, lag(2 2)) iv(ageweek-hhstructweek nmembersweek age_grpweek-hhstruct_grpweek, eq(level)) cluster(centerid);


I don't see week and week2 anywhere in the instrument list. Recall that in Roodman's -xtabond2- everything before the comma generally should also appear after the comma. Try dropping some of the regressors and just fitting it with the LDV and one or two IV instruments and see what happens. Presuming you're using Stata 12, memory allocation should be automatic.

Kit


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index