Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, is already up and running.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: ologit models with weights errors

From   Richard Williams <>
Subject   Re: st: ologit models with weights errors
Date   Mon, 14 Nov 2011 08:37:07 -0500

At 08:14 AM 11/14/2011, abby schwartz wrote:
Greetings all,

I am running ologits on a weighted data set. I continue to get various
error messages.
After running an ologit I attempt to run brant, detail; listcoef, std
help; and fitstat. I receive the following error messages:

svy: brant, detail
last estimates not found

svy: listcoef, std help
last estimates not found

svy: fitstat
last estimates not found

If I just type "brant, detail" without the svy: I get the error message:
-brant- does not work with ologit models with weights

Any help would be appreciated. Many thanks.

Make sure you have the most current version of -spost9-. For example, with listcoef, the most current version is

. which listcoef
*! version 1.9.3 2010-12-21 scott long

When I run the following commands,

webuse nhanes2f
svy: ologit health female black
brant, detail
listcoef, std

brant and fitstat do not work, but listcoef does. Either Scott Long hasn't gotten around to programming svy support, or (more likely) the commands are not appropriate with svy data.

Richard Williams, Notre Dame Dept of Sociology
OFFICE: (574)631-6668, (574)631-6463
HOME:   (574)289-5227
EMAIL:  Richard.A.Williams.5@ND.Edu

*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index