Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Other forums [was: RE: st: RE: how to force same excluded groups across regression models]


From   Richard Goldstein <richgold@ix.netcom.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: Other forums [was: RE: st: RE: how to force same excluded groups across regression models]
Date   Wed, 12 Oct 2011 15:27:58 -0400

sorry; I suggest you contact tech-support and send them the exact code
you attempted to use with -xtreg-; also include a detailed description
of what you mean by not working with -xtreg-

Rich

On 10/12/11 3:16 PM, Megan Sheahan wrote:
> Richard - I think you pointed me in the correct direction. Thanks!
> However, it seems to work for -regress-, but not when I regress using
> -xtreg-. Any thoughts on why that might be? There is no help in the
> manual.
> 
> Fernando - Thanks for your suggestion. Stata still does strange things
> when I create separate dummies for each category and interact them
> separately.
> 
> Megan
> 
> On Wed, Oct 12, 2011 at 11:54 AM, Fernando Rios Avila
> <f.rios.a@gmail.com> wrote:
>> Hi Megan,
>> I know this is a more simple solution, but perhaps you should try to
>> create the dummies and interaction terms before the different
>> specifications are estimated, so you can have more control on which
>> variable is used as baseline reference.
>> regards,
>> Fernando
>>
>> On Wed, Oct 12, 2011 at 2:38 PM, Megan Sheahan <megan.sheahan@gmail.com> wrote:
>>> Thanks Nick. I'll try my question again on here.
>>>
>>> I am attempting to run the same model as pooled OLS, fixed effects,
>>> and CRE. There are a number of interaction terms in my model with
>>> categorical variables. When Stata runs these three models, it chooses
>>> different groups to exclude in the FE model than in the OLS and CRE
>>> models, making the output difficult to compare. For example, I am
>>> interacting three zone groups and four soil groups with N. The CRE and
>>> OLS models keep all three zones and omit the fourth soil group. The FE
>>> model omits the first zone and keeps all four soil groups. Is there
>>> any way to tell Stata to exclude the same groups across regression
>>> models? I tried the following command, but it did not fix the problem:
>>> char varname[omit].
>>>
>>> For reference, here is the syntax for the three models:
>>>
>>> /* POOLED OLS */ regress yield_ha c.N_ha#zone_comb
>>> c.N_ha#c.N_ha#zone_comb c.N_ha#c.P_ha#zone_comb
>>> c.N_ha#soil_group_megan c.N_ha#c.rain_stress#zone_comb seed_ha
>>> c.seed_ha#c.seed_ha hectares c.hectares#c.hectares masset_ha
>>> c.masset_ha#c.masset_ha rain_stress i.manure i.hybrid
>>> c.rain_stress#hybrid i.legume i.crop_per_field i.dist i.FAO_class
>>> i.year if prod_func == 1, cluster(hhid)
>>>
>>> /* FE */ xtreg yield_ha c.N_ha#zone_comb c.N_ha#c.N_ha#zone_comb
>>> c.N_ha#c.P_ha#zone_comb c.N_ha#soil_group_megan
>>> c.N_ha#c.rain_stress#zone_comb seed_ha c.seed_ha#c.seed_ha hectares
>>> c.hectares#c.hectares masset_ha c.masset_ha#c.masset_ha rain_stress
>>> i.manure i.hybrid c.rain_stress#hybrid i.legume i.crop_per_field
>>> i.dist i.FAO_class i.year if prod_func == 1, fe i(hhid) cluster(hhid)
>>>
>>> /* CRE, WITH POOLED OLS STRUCTURE */ regress yield_ha c.N_ha#zone_comb
>>> c.N_ha#c.N_ha#zone_comb c.N_ha#c.P_ha#zone_comb
>>> c.N_ha#soil_group_megan c.N_ha#c.rain_stress#zone_comb seed_ha
>>> c.seed_ha#c.seed_ha hectares c.hectares#c.hectares masset_ha
>>> c.masset_ha#c.masset_ha rain_stress i.manure i.hybrid
>>> c.rain_stress#hybrid i.legume i.crop_per_field i.dist i.FAO_class
>>> i.year mN_ha mP_ha mseed_ha mhectares mrain_stress mmanure mhybrid
>>> mlegume mcrop_per_field if prod_func == 1, cluster(hhid)
>>>
>>> Many thanks in advance for your suggestions.
>>>
>>> Megan
>>>
>>>
>>> On Wed, Oct 12, 2011 at 11:22 AM, Nick Cox <n.j.cox@durham.ac.uk> wrote:
>>>> Stata tech support, if it falls within their remit?
>>>>
>>>> The main other forum I know of is Stack overflow. There is much less Stata traffic there than on this list.
>>>>
>>>> StataCorp is now on Facebook and Twitter but neither seems well suited to detailed technical questions or answers.
>>>>
>>>> Without bias, and without prejudice of any kind, I'd say that there are more, and more active, experts on this list...
>>>>
>>>> But what is it that can't be answered in this forum?
>>>>
>>>> Very broadly, and without reference to your thread, three main kinds of questions have low probabilities of getting detailed answers on this list. These are expressed in their limiting forms:
>>>>
>>>> * How should I analyse my data?
>>>>
>>>> * I am doing X. Is this correct?
>>>>
>>>> * I am new to Stata. Please give me a personal tutorial on A and B.
>>>>
>>>> And I don't think other lists are, in practice, more reactive to such questions.
>>>>
>>>> Nick
>>>> n.j.cox@durham.ac.uk
>>>>
>>>> Megan Sheahan
>>>>
>>>> Thanks again, Dave. For the broader audience, do you happen to know
>>>> where else I can submit a Stata question if it can't be answered
>>>> through this listserv?
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index