Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: stepwise regression coefficients change each time the program is run


From   Nina Joyce <ninarjoyce@gmail.com>
To   statalist <statalist@hsphsun2.harvard.edu>
Subject   st: stepwise regression coefficients change each time the program is run
Date   Wed, 21 Sep 2011 09:07:33 -0400

Hi,
 I have been having this problem for about six months now. Here's the
background: I have a dataset with patient information that I link to a
dataset with physician information.  So it is a many-to-one merge.
There are about 50K patients and 40 physicians.  After they are
merged, I do a bunch of data cleaning and variable creation and then
draw a random sample of 50% to derive the model.  I use a stepwise
regression (i know, i hate it too).  Here's the problem: If I merge
the datasets, do all the data cleaning and then run the stepwise
regression, I get a different model every time.  However, if I merge
the datasets, save it, close it down and then reopen it before doing
the data cleaning and drawing the sample, as long as I use that same
dataset I get the same model every time. Which means that it has to be
something that happens before I save the dataset, and the only thing
that I do before saving is the merge.
thanks so much for any suggestions.

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index