Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: re: unable to compute for collinearity diagnostics


From   Kouji Asakura <asakura.koji@yahoo.com>
To   statalist digest <statalist@hsphsun2.harvard.edu>
Subject   st: re: unable to compute for collinearity diagnostics
Date   Tue, 23 Aug 2011 18:44:29 -0700 (PDT)

Hi Statalisters,

I am having a bit of a problem in computing for the collinearity diagnostics after running my logistic regression model. I tried running the command 'collin', and stata returned the following results:

(obs=1103)
matrix has missing values
r(504);


( [P]     error . . . . . . . . . . . . . . . . . . . . . . . .  Return code 504
        matrix has missing values;
        You have issued a matrix command attempting a matrix operation
        that, were it carried out, would result in a matrix with missing
        values; dividing by zero is a good example. )

I tried running the 'collin' command for my other logistic regression models and it worked just fine. There's just this one model where it doesn't seem to work. I checked all my observations and none of them have missing values. Would appreciate any help on how to remedy this problem

Also, is it valid to just use the Variance Inflation Factor computed if i ran the model in OLS instead of logistic?


Thanks!

Regards, 


Kouji Asakura

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index