Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: ivreg2 with weight: results slightly different to those 3 months ago


From   "sdm1" <sdm1@york.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: ivreg2 with weight: results slightly different to those 3 months ago
Date   Mon, 18 Oct 2010 18:06:38 +0100

I have been re-running a do file that I last ran in July and I have been
getting slightly different results for most parts of the regression output
when using -ivreg2- with weights (-ivreg2- without weights generates
identical results).  For example, the Kleibergen-Paap rk LM statistic and
Kleibergen-Paap Wald rk F statistic are the same as they were in July but
most of the output changes slightly (including the regression coefficients).

I am now using:

. which ivreg2
c:\ado\plus\i\ivreg2.ado
*! ivreg2 3.0.05  17June2010

I guess that I must have updated the ado file sometime between July and now
because today's log file includes Angrist-Pischke (AP) statistics but the
July log file does not (it first reports Shea's Partial R2).  I do not know
which version of ivreg2 I was using previously.  Sorry!

In both cases I am estimating the same model:

ivreg2 lallcancersdsmr lneed89HPandG (lg2_89expphHPandG=llonepenhx
lpoppucarx) [w=rawpop89], gmm2s robust ffirst endog(lg2_89expphHPandG)

Have changes been made to -ivreg2- (perhaps fairly recently) which would
account for this?

Steve

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index