Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: why one ml program doesn't give the same results twice ?


From   Valerie Orozco <Valerie.Orozco@toulouse.inra.fr>
To   "statalist@hsphsun2.harvard.edu" <statalist@hsphsun2.harvard.edu>
Subject   st: why one ml program doesn't give the same results twice ?
Date   Tue, 4 May 2010 09:07:18 +0000

Hi,

I wonder why a whole ml program doesn't give the same results twice in one Stata session ?
That is, doing the following steps doesn't give the same estimation : 

1) Run my ml model and ml maximize
2) Clear all  (mat drop _all + ereturn clear + ml clear)
3) "Re"run my ml model and ml maximize

It seems some "saved" results still remain and affect the second estimation. What did I forget to clear ?
(if I close the Stata session and open another one, it gives the same results)

Thank you very much for your help.

valérie

-------------------------------
Valérie OROZCO
Toulouse School of Economics (INRA-GREMAQ)
21, allée de Brienne
F-31000 Toulouse, France

MA 101
+33 5 61 12 85 91
-------------------------------


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index