Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down on April 23, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: st: AW: rename files - "! rename" doesn't work


From   Hewan Belay <hewan_belay@yahoo.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: AW: rename files - "! rename" doesn't work
Date   Fri, 16 Apr 2010 09:51:35 -0700 (PDT)

Dear Martin and Nick,

Thanks for your ideas. Indeed, it works when I include only the filename in the second term, i.e. when instead of 

 ! rename "D:\myauto.dta"  "D:\yourauto.dta"

I use

 ! rename "D:\myauto.dta"  yourauto.dta"

Best,
Hewan

--- On Fri, 4/16/10, Martin Weiss <martin.weiss1@gmx.de> wrote:

> From: Martin Weiss <martin.weiss1@gmx.de>
> Subject: st: AW: rename files - "! rename" doesn't work
> To: statalist@hsphsun2.harvard.edu
> Date: Friday, April 16, 2010, 2:44 PM
> 
> <> 
> 
> -cd-ing beforehand help as well:
> 
> 
> *************
> clear*
> cd C:\
> webuse auto, clear
> save "myauto.dta", replace
> dir *dta
> !ren "myauto.dta"  "yourauto.dta"
> dir *dta
> *************
> 
> 
> 
> HTH
> Martin
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: owner-statalist@hsphsun2.harvard.edu
> [mailto:owner-statalist@hsphsun2.harvard.edu]
> Im Auftrag von Hewan Belay
> Gesendet: Freitag, 16. April 2010 16:21
> An: Stata List
> Betreff: st: rename files - "! rename" doesn't work
> 
> Dear stata list,
> 
> Following Nick's guidelines in
>  http://www.stata.com/statalist/archive/2008-05/msg00254.html
> 
> I tried to rename dta files from within stata but it didn't
> work. Here is
> what I tried:
> 
> webuse auto
> save "D:\myauto.dta", replace
> ! rename "D:\myauto.dta"  "D:\yourauto.dta"
> 
> All that happens is, a small window flashes in and then
> back out in a split
> of a second. When I go to Windows explorer and look at the
> D/ folder, I
> still find myauto there, not yourauto. I refreshed the
> windows explorer, and
> also closed and opened it again, but it's still myauto. By
> way of
> information, my operating system is Windows XP
> Professional, and I'm using
> Stata 11. I tried the above also with -shell rename-
> instead of -! rename-,
> but the same thing happens. What could be the problem?
> 
> Thanks,
> Hewan
> 
> 
> 
>       
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
> 
> 
> *
> *   For searches and help try:
> *   http://www.stata.com/help.cgi?search
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
> 


      

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index