Bookmark and Share

Notice: On March 31, it was announced that Statalist is moving from an email list to a forum. The old list will shut down at the end of May, and its replacement, statalist.org is already up and running.


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: rename files - "! rename" doesn't work


From   Hewan Belay <hewan_belay@yahoo.com>
To   Stata List <statalist@hsphsun2.harvard.edu>
Subject   st: rename files - "! rename" doesn't work
Date   Fri, 16 Apr 2010 07:21:05 -0700 (PDT)

Dear stata list,

Following Nick's guidelines in
 http://www.stata.com/statalist/archive/2008-05/msg00254.html 
I tried to rename dta files from within stata but it didn't work. Here is what I tried:

webuse auto
save "D:\myauto.dta", replace
! rename "D:\myauto.dta"  "D:\yourauto.dta"

All that happens is, a small window flashes in and then back out in a split of a second. When I go to Windows explorer and look at the D/ folder, I still find myauto there, not yourauto. I refreshed the windows explorer, and also closed and opened it again, but it's still myauto. By way of information, my operating system is Windows XP Professional, and I'm using Stata 11. I tried the above also with -shell rename- instead of -! rename-, but the same thing happens. What could be the problem?

Thanks,
Hewan



      
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   Site index