Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: RE: [XTIVREG2] Cause of Errors? IV or Cluster {Update doesn't help me}


From   "Nick Cox" <n.j.cox@durham.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   RE: st: RE: [XTIVREG2] Cause of Errors? IV or Cluster {Update doesn't help me}
Date   Wed, 26 Aug 2009 18:39:28 +0100

Updating your user-written ado files through -ssc- does nothing to the
official Mata installation. 

I think Mark means that you should -update- your Stata. You don't answer
his question on whether you did that. 

Nick 
n.j.cox@durham.ac.uk 

javanfish (a.k.a. Sungbok Lee, TAMU) 

I wish that -update- resolve these errors. But still.

. which ivreg2
c:\ado\plus\i\ivreg2.ado
*! ivreg2 2.2.09  17jul2008
*! authors cfb & mes
*! see end of file for version comments

. which xtivreg2
c:\ado\plus\x\xtivreg2.ado
*! xtivreg2 1.0.09 4Nov2007
*! author mes

. which ranktest
c:\ado\plus\r\ranktest.ado
*! ranktest 1.1.03  4May2008
*! author mes, based on code by fk

. ssc install ranktest
checking ranktest consistency and verifying not already installed...
all files already exist and are up to date.

. ssc install ivreg2
checking ivreg2 consistency and verifying not already installed...
all files already exist and are up to date.

. ssc install xtivreg2
checking xtivreg2 consistency and verifying not already installed...
all files already exist and are up to date.

Does it depend on the version of STATA? Someone mentioned about it but I
am not sure.

"Schaffer, Mark E" <M.E.Schaffer@hw.ac.uk>

Which versions of -xtivreg2-, -ivreg2- and -ranktest- are you using?

And have you updated your version of Stata with -update all-?

In my experience these Mata errors usually go away after a full
updating.


>> [mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of javanfish

>> What am I supposed to do for this error?
>>
>> xi: xtivreg2 y (x1 x2 x3  = iv1 iv2 iv3 iv4 iv5) i.time, fe small
>> cluster(group)
>>
>> i.time            _Itime_1-50     (naturally coded; _Itime_50
omitted)
>>
>> Warning - singleton groups detected.  1 observation(s) not used.
>>           panelsetup_u():  3301  subscript invalid
>>               panelsetup():     -  function returned error
>>                      rkstat():     -  function returned error
>>                     <istmt>:     -  function returned error
>>
>> I followed the prevous directions. But Still.
>> My stata is version 10 with 64-bit
>
>
>> Just in case, I experimented why it has the errors.
>>
>> xi: xtivreg2 y (x1 x2 x3  = iv1 iv2 iv3 iv4 iv5) i.time, fe
>> small   --> no
>> errors
>>
>> xi: xtivreg2 y x1^ x2^ x3^ i.time, fe small cluster(group)
>> --> no errors
>>
>> where X1^ indicates the instrumented value of x1 in the first stage.
>>
>>
>> I hope these experiments to help you to answer me.

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index