Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

st: AW: combining data from multiple excel sheets into data file


From   "Martin Weiss" <martin.weiss1@gmx.de>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: AW: combining data from multiple excel sheets into data file
Date   Mon, 1 Jun 2009 22:33:00 +0200

<> 

Have you tried Roger`s 

*************
ssc d stcmd
*************

? Apart from that, you could also contact Stat/Transfer tech support...

HTH
Martin


-----Ursprüngliche Nachricht-----
Von: owner-statalist@hsphsun2.harvard.edu
[mailto:owner-statalist@hsphsun2.harvard.edu] Im Auftrag von Joelle Wolstein
Gesendet: Montag, 1. Juni 2009 22:23
An: statalist@hsphsun2.harvard.edu
Betreff: st: combining data from multiple excel sheets into data file

Hello. I know this isn't technically a Stata questions but I figured I
may as well post it to the list since I got Stat/Transfer from Stata.

I am having trouble combining my files.

I am using the following command:
st>  combine /users/xxxx/desktop/name_test/*.xls datamay29.dta
"-tTCABEvalTeamData"

The excel files I am using have 4 sheets, one of which is called TCAB
Eval Team Data. The TCAB Eval Team Data sheet has 45 variables.

When I run the command I get the following message:
Worksheet Page Name: TCAB Eval Team Data is invalid

The program proceeds to pick up 1 variable from the first sheet in
each of the 120+ excel files, not from the TCAB Eval Team Data sheet.
The following is the message it gives me:

Transferring to Stata: /users/xxxx/desktop/data20090529.dta
1 variables and 1 records read from /users/xxxx/desktop/name_test/T1001.xls

Worksheet Page Name: TCAB Eval Team Data is invalid
1 variables and 1 records read from /users/xxxx/name_test/T1002.xls

Worksheet Page Name: TCAB Eval Team Data is invalid
1 variables and 1 records read from /users/xxxx/desktop/name_test/T1003.xls

etc.

It seems that the -t command isn't reading the spaces in the sheet
name correctly.

I have tried -t2 (the sheet number) as well as  "-tTCAB Eval Team
Data",  "-tTCAB_Eval_Team_Data", and  "-tTCAB@20Eval@20Team@20Data"

Has anyone else run into this problem? Any suggestions?

Thank you,
Joelle
*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/


*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index