Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: st: Db with an ado


From   "Tharyan, Rajesh" <R.Tharyan@exeter.ac.uk>
To   "statalist@hsphsun2.harvard.edu" <statalist@hsphsun2.harvard.edu>
Subject   RE: st: Db with an ado
Date   Wed, 29 Apr 2009 15:03:23 +0100

The problem happens only when I use it within a do or an ado file. No problems when I issue the commands via the interactively. I use stata 10.1.

thanks

-----Original Message-----
From: owner-statalist@hsphsun2.harvard.edu [mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of Maarten buis
Sent: 29 April 2009 14:53
To: statalist@hsphsun2.harvard.edu
Subject: Re: st: Db with an ado


--- On Wed, 29/4/09, Tharyan, Rajesh wrote:
> When I issue a command followed by by a request statement
> as in something like below..
> 
> . db use
>  . di "do you want to list: (enter 1 for yes 2 for no)
> " _request(_answer)
> do you want to list: (enter 1 for yes 2 for no) . use
> "C:\data\results.dta", clear
> 
> Stata automatically uses the echo from the db use command
> as _answer. Is there anyway to prevent this?

Sounds like there is something wrong with your Stata 
instalation. The first thing you could try is type:

update all
update swap

Hope this helps,
Maarten

-----------------------------------------
Maarten L. Buis
Institut fuer Soziologie
Universitaet Tuebingen
Wilhelmstrasse 36
72074 Tuebingen
Germany

http://home.fsw.vu.nl/m.buis/
-----------------------------------------





      

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/help.cgi?search
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index