Statalist


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Strange behaviour with passing parameters to a Stata program


From   "Salah Mahmud" <salah.mahmud@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Strange behaviour with passing parameters to a Stata program
Date   Sun, 13 Jul 2008 00:09:41 -0500

Thanks!
It works perfectly now.

On Sun, Jul 13, 2008 at 1:03 AM, Richard Williams
<Richard.A.Williams.5@nd.edu> wrote:
> At 11:44 PM 7/12/2008, Salah Mahmud wrote:
>>
>> Stata completely ignores the notab parameter when it is passed to the
>> program below.
>> On tracing, notab is always =="" no matter what. Change the parameter
>> name in the syntax statement to anything else and it works as
>> expected. Anybody knows what is going on?
>>
>> I'm running Stata MP v10  born 27 May 2008
>
> I've always considered that an odd and confusing feature of Stata syntax.
>  See -help syntax- and search for the text "Warning:  be careful if the
> first two letters of the option's name are no".  Read that and the next
> section entitled "option_descriptor optionally_off".
>
>
> -------------------------------------------
> Richard Williams, Notre Dame Dept of Sociology
> OFFICE: (574)631-6668, (574)631-6463
> HOME:   (574)289-5227
> EMAIL:  Richard.A.Williams.5@ND.Edu
> WWW:    http://www.nd.edu/~rwilliam
>
> *
> *   For searches and help try:
> *   http://www.stata.com/support/faqs/res/findit.html
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index