Statalist The Stata Listserver

[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Question about survey command and errors

From (Jeff Pitblado, StataCorp LP)
Subject   Re: st: Question about survey command and errors
Date   Mon, 07 May 2007 13:09:54 -0500

Tewarit Somkotra (via forwarded email from Marcello Pagano) is having trouble
with the -svy- prefix in Stata 9:

> I recently have been running the STATA9 for data analysis since my 
> department bought this version, before that, I had run by STATA8 
> without any problems when I used the survey command. Since I started 
> to try to run survey command by STATA9, I got an error about the 
> _robust2, then I checked and tried to solve problem by using the 
> reference books, help command and searching about FAQ, but I could not 
> get the solution yet. Therefore, I decide to ask you for some help 
> about this big error. Would you please do me a favor, or give me some 
> suggestion about the solution to solve this problem.
> Here, this is the example about the error after I tried to run the 
> data by using svy command.
> . svyset psu_no [pweight=weight], strata(cwt) vce(linearized)
>       pweight: weight
>           VCE: linearized
>      Strata 1: cwt
>          SU 1: psu_no
>         FPC 1: <zero>
> . svy:  logit  opdutil_cat3  lnhhinceq  $decompose1  $decompose2
> (running logit on estimation sample)
>                  <istmt>:  3499  _robust2() not found
> Mata run-time error
> r(3499);
> Thank you very much for your kindness.

It appears that Tewarit's Stata 9 executable is out of sync with the
ado-files.  Tewarit should run the following command in Stata:

	. update query

and following the recommendation at the end of its output.

Tewarit can write directly to Tech Support <> if the
above does not solve the problem.

*   For searches and help try:

© Copyright 1996–2015 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index