Statalist The Stata Listserver


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Error from replicating -ice- result on UNIX system


From   "Ada C. Chen" <ada08chen@gmail.com>
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Error from replicating -ice- result on UNIX system
Date   Thu, 22 Mar 2007 17:37:10 -0400

Thank you for both responses. I already updated all. To check whether
I made the mistake Nick said, and since my syntax took too long to run
in Windows, I'll condense it into short version, and try to run it in
both Window and Unix again. Hopefully this time it will work in UNIX.

Vivien


2007/3/22, Stas Kolenikov <skolenik@gmail.com>:
The problem I am often finding with the big computing environments is
that they might be sluggish with Stata updates -- doing those once in
a quarter or so (understandably, if they have 50 other programs to
maintain, and C++ compilers are probably used 50 times more often than
Stata in a typical university setting). Check for updates for
everything, including -ice- itself.

On 3/22/07, n j cox <n.j.cox@durham.ac.uk> wrote:
> There is little precise information here, but
> enough to guess that you are probably looking in
> the wrong direction.
>
> If you ran _exactly_ the same command on _exactly_
> the same dataset, once on Unix and once on
> your PC (you don't say what OS, but I guess Windows),
> and got the difference you report, then that would
> be very puzzling indeed. But the error message
> would then be most unlikely to be that given here.
> Assuming that -ice- is correct, the problem
> will be true regardless of platform. Also,
> I would be surprised if -ice- had any machinery
> that was platform-dependent.
>
> No; my guess is that something else is different,
> your dataset or your syntax, but you are just
> not aware of it -- and not telling us.
>
> The -ice- package on SSC underlines that Patrick
> Royston, the author of -ice-, is not a member
> of Statalist.
>
> Nick
> n.j.cox@durham.ac.uk
>
> Ada C. Chen
>
> I run my -ice- program (for multiple imputation) in my PC, and it took
> me almost 50 hours for one imputation, but I got the result without
> error message. To fasten the imputation process, I tried to replicate
> the same program in UNIX system, but I got error message as:
> "invalid, ssesp is passively imputed" when it should be estimated with a
> logit.
>
> I wonder if there is anything wrong with the passive subcommand or
> anything I should have taken care of when I run a STATA program in
> UNIX system.
> *
> *   For searches and help try:
> *   http://www.stata.com/support/faqs/res/findit.html
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
>


--
Stas Kolenikov
http://stas.kolenikov.name
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index