Statalist The Stata Listserver


[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Stata under Debian


From   ariley@stata.com (Alan Riley)
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Stata under Debian
Date   Mon, 12 Jun 2006 15:35:25 -0500

Brendan Halpin (brendan.halpin@ul.ie) is having problems running
Stata 9 on a system with only GTK 2 on it:
> I've upgraded my installation of Debian, and xstata has ceased to
> work, with the following error:
> 
> xstata: error while loading shared libraries: libgtk-1.2.so.0:
> cannot open shared object file: No such file or directory
> 
> I've gotten around problems like this before by symlinking to the
> existing libraries, but this doesn't work now (GTK is now version 2.0,
> I think).

Stata 9 requires GTK 1.2.  GTK 2 and GTK 1.2 can coexist on the same
Unix system without conflicts.  Go to

   http://www.debian.org/distrib/packages/

and search for

   libgtk1.2

to find the packages you need to install to add support for GTK 1.2 to
your system.  Or, you can go to

   http://www.gtk.org/download/

if you prefer to download and compile GTK 1.2 from source.


Alan
(ariley@stata.com)
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index