Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: Re: nestreg and survey logistic


From   Steve <drlead@prodigy.net.mx>
To   statalist@hsphsun2.harvard.edu
Subject   st: Re: nestreg and survey logistic
Date   Sat, 12 Nov 2005 08:55:34 -0600

Sorry for the duplicate postings. I've traced the problem to my e-mail server not delivering all my mail.

Steve

----- Original Message ----- From: "Steve" <drlead@prodigy.net.mx>
To: <statalist@hsphsun2.harvard.edu>
Sent: Saturday, November 12, 2005 8:44 AM
Subject: nestreg and survey logistic



Dear Stata Folk,

Stata exec and ado updated today on a WinXP system. Using Stata SE.

I've been trying out the new prefix command -nestreg-, repeating a sequence
of analyses I've already done by hand.

The command syntax presents the two nested analyses correctly but then exits
strangely with the message that -svy- was not found. The run is reproduced
below:

. nestreg: svy: logistic past (store_water pluvial AC people vicinity
cross3 aegypti missinginc inc100 intact) (city)

Block 1: store_water pluvial AC people vicinity cross3 aegypti missinginc
inc100 intact
(running logistic on estimation sample)

Survey: Logistic regression

Number of strata = 2 Number of obs =
578
Number of PSUs = 100 Population size =
524546.74
Design df =
98
F( 10, 89) =
3.96
Prob > F =
0.0002

------------------------------------------------------------------------------
| Linearized
past | Odds Ratio Std. Err. t P>|t| [95% Conf.
Interval]
-------------+----------------------------------------------------------------
store_water | 1.462093 .405928 1.37 0.174 .842747
2.536604
------------OUTPUT EDITED------------------------
------------------------------------------------------------------------------Block 2: city(running logistic on estimation sample)Survey: LogisticregressionNumber of strata = 2 Number of obs=578Number of PSUs = 100 Population size=524546.74 Design df=98 F( 11, 88) =6.70Prob > F =0.0000------------------------------------------------------------------------------ | Linearized past | Odds Ratio Std. Err.t P>|t| [95% Conf.Interval]----------------------------------------------------------------------------- store_water | .8597424 .2587414 -0.50 0.617 .47314551.562219-------------OUTPUT EDITED -----------------------------------------------------------------------------------------svy not found r(111);_____Since the Wald table is the default in the -nestreg- command, I wasexpecting the table to appear instead of the error message. Have I made asimple syntax error or is there a bug in this new prefixcommand when usingsurvey regressions?Steve RothenbergCINVESTAV-IPNMérida, México

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index