Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: nestreg and survey logistic


From   jpitblado@stata.com (Jeff Pitblado, StataCorp LP)
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: nestreg and survey logistic
Date   Thu, 10 Nov 2005 22:20:30 -0600

Steve <drlead@prodigy.net.mx> found a bug in -nestreg-:

> Stata exec and ado updated today on a WinXP system. Using Stata SE.
> 
> I've been trying out the new prefix command -nestreg-, repeating a sequence 
> of analyses I've already done by hand.
> 
> The command syntax presents the two nested analyses correctly but then exits 
> strangely with the message that -svy- was not found. The run is reproduced 
> below:
> 

(example omitted)

> Since the Wald table is the default in the -nestreg- command, I was 
> expecting the table to appear instead of the error message.
> 
> Have I made a simple syntax error or is there a bug in this new prefix 
> command when using survey regressions?

Steve found a bug in -nestreg- when used with a survey estimation command
other than -svy: regress-.  We have fixed -nestreg- and will post it in the
next ado-file update.

--Jeff
jpitblado@stata.com
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index