Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: obvious error?


From   "Nick Cox" <n.j.cox@durham.ac.uk>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: obvious error?
Date   Tue, 18 Oct 2005 18:38:36 +0100

The best test here that you and Stata 
are speaking the same language is to 

. mac li 

to see what Stata is holding in local 
macros. If you typed, as stated here, 

. local x1lsr age age2 hgc

then the local macro -x1lsr- will
hold "age age2 hgc" and it is entirely 
possible that the local macro -x1- 
is not defined. 

But I can't see what is wrong with 
your other example. 

Stata is not _asking_ for last estimates. 
It can't see any variable names, so is 
presuming that you are asking for a replay; 
but it can't oblige, as it cannot find 
the last estimates from that command. 

Nick 
n.j.cox@durham.ac.uk 

Scott Cunningham
 
> This is stumping me.  Here's a sample of my code and the error I'm  
> getting.  I know I'm doing some obviously wrong, but it's so obvious  
> that I can't see it.
> 
> . local y rp
> . local x1lsr age age2 hgc
> . local x3 lsr age age2 hgc i.year state*
> 
> . xi: xtreg `y' `x1', fe i(id) robust
> last test not found
> r(302);
> 
> I get the same error even when I run the following regression:
> 
> . xi: xtreg `y' `x3', fe i(id) robust
> last estimates not found
> r(301);
> 
> So I know it's not just the fact that I'm using the -xi- operator  
> without including the year dummies for the first FE regression.  Why  
> is it asking me for "last estimates"?
> 

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index