Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: RE: mat procedure won't run in V9


From   "Garrard, Wendy M." <wendy.garrard@Vanderbilt.Edu>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: RE: mat procedure won't run in V9
Date   Sun, 11 Sep 2005 11:03:04 -0500

Sorry about not clarifying the --metaregW-- command. This macro is
documented in Lipsey & Wilson's (2001) Practical Meta-Analysis, and is
available on David Wilson's website
(http://mason.gmu.edu/~dwilsonb/ma.html). Wilson's macro was originally
named --metareg--, but this conflicts with another widely-used Stata
macro name, so I changed the name to metaregW for my use.

The mat / loop procedure ran fine under version 8. Indeed, I used it
quite a bit to get these special type (weighted random effects
bivariate) correlations.  I only recently tried to use the procedure
with version 9, and now it doesn't work properly. 

Regards,
wg

-----Original Message-----
From: owner-statalist@hsphsun2.harvard.edu
[mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of Nick Cox
Sent: Sunday, September 11, 2005 10:41 AM
To: statalist@hsphsun2.harvard.edu
Subject: st: RE: mat procedure won't run in V9

This uses a procedure -metaregW-. 

The Statalist FAQ advises 

"Say what command(s) you are using. 
If they are not part of official Stata, say where they come from: the
STB/SJ, SSC, or other archives." 

. findit metaregW 

finds nothing, and a Google search seems to find nothing much except
your own previous references to
-metaregW- in Statalist postings, so for I all know it is your own
program. 

In general I suspect the problem is nothing to do with Stata 9. You must
use exactly the same names as -metaregW- to pick up its results.  
-return list- after -metaregW- will tell you what -metaregW- returns. 

Nick
n.j.cox@durham.ac.uk 

Garrard, Wendy M.

> I am hoping someone can help me get this bit of code (developed in 
> v.8) to run in v9.
> The commands are below, and when it works properly, it calls a 
> "meta-regression" macro and produces a list (matrix) of bivariate 
> weighted random effects correlations between the effect size and each 
> variable in the varlist.
> 
> This is the first time I've tried to use this do-file in v9, and no 
> correlations are showing up in the (oblong) matrix.
> 
> Any suggestions?  Thanks very much
> --wg
> 
> *********************
> /*START*/
> mat res = J(20,2,0)
> local i 0
> foreach v of varlist   var1 var2 var3 var4 var5  {
> 	qui metaregW es_adjRndwz `v' [aw=weight] , model(ml)
> 	*summarize `v'
>       local ++i
>       mat res[`i',1] = r(corr)
>       mat res[`i',2] = r(pr)
>       local rl "`rl' `v'"
> 	          }
> mat rownames res = `rl'
> mat colnames res =  Corr(ml)  p-value
> mat list res, f(%9.3f)
> /*STOP*/

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index