Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

RE: st: -nl- error message


From   "Steichen, Thomas J." <SteichT@rjrt.com>
To   <statalist@hsphsun2.harvard.edu>
Subject   RE: st: -nl- error message
Date   Tue, 9 Aug 2005 08:27:29 -0400

Yes, what is happening is your list of global parameters has a mismatch...

For example: 

  .   global S_1 "B0 B1 B2"
  .   global B0=1
  .   global B7=1
  .   global B2=1


Note B1 expected but B7 defined.

Tom

Thomas J. Steichen
steicht@rjrt.com
----------------------------------------------------------------------------
  Facts do not cease to exist because they are ignored. - Aldous Huxley
----------------------------------------------------------------------------



> -----Original Message-----
> From: owner-statalist@hsphsun2.harvard.edu 
> [mailto:owner-statalist@hsphsun2.harvard.edu] On Behalf Of 
> Michael Blasnik
> Sent: Monday, August 08, 2005 7:17 PM
> To: statalist@hsphsun2.harvard.edu
> Subject: Re: st: -nl- error message
> 
> 
> I would guess that the bug is in your code and not in Stata, 
> but I can't tell from the snippet provided.  All I can tell 
> is that, given that `j' evaluates to 1, Stata did not find a 
> global macro named ${`1'} so it left a blank there when it 
> ran your code.
> 
> Michael Blasnik
> michael.blasnik@verizon.net
> 
> ----- Original Message ----- 
> From: "Terra Curtis" <terra.curtis@cambridgefinance.com>
> To: <statalist@hsphsun2.harvard.edu>
> Sent: Monday, August 08, 2005 11:02 AM
> Subject: RE: st: -nl- error message
> 
> 
> > So I ran my code after setting trace on ('set trace on') 
> and I think I 
> > may have found a bug in STATA itself.  I saved the trace as 
> a log file 
> > and the part concerning the invalid syntax appears here:
> >
> > Iteration 0:    - if "`trace'"!="" { noi di }
> >   = if ""!="" { noi di }
> >   - }
> >   - local j 1
> >   - while `j' <= `np' {
> >   = while 1 <= 23 {
> >   - local old_pj = ${``j''}
> >   = local old_pj =
> > invalid syntax
> >
> > It appears that the problem lies deeper than in my .do 
> file.  The last
> line
> > before "invalid syntax" shold report that old_pj equals 1 (i.e. = 
> > local old_pj = 1).  Any ideas if this is a bug, and if so, 
> how to go 
> > about
> fixing
> > it?
> >
> > Thanks,
> > Terra
> 
> 
> *
> *   For searches and help try:
> *   http://www.stata.com/support/faqs/res/findit.html
> *   http://www.stata.com/support/statalist/faq
> *   http://www.ats.ucla.edu/stat/stata/
> 

-----------------------------------------
CONFIDENTIALITY NOTE: This e-mail message, including any attachment(s),
contains information that may be confidential, protected by the attorney-
client or other legal privileges, and/or proprietary non-public
information. If you are not an intended recipient of this message or an
authorized assistant to an intended recipient, please notify the sender by
replying to this message and then delete it from your system. Use,
dissemination, distribution, or reproduction of this message and/or any of
its attachments (if any) by unintended recipients is not authorized and may
be unlawful.


*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index