Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: ml check shows errors but ml maximize works


From   Alita Nandi <alita.nandi@chrr.ohio-state.edu>
To   statalist@hsphsun2.harvard.edu
Subject   st: ml check shows errors but ml maximize works
Date   Wed, 25 May 2005 12:42:59 -0400

Hello,

--ml check-- gives the error message "cannot find feasible values" when it is testing to see whether the likelihood evaluator (the program that I have written to calculate the log-likelihood) works or not. But when I run --ml maximize-- without running --ml check-- before it, the maximization works and I get the estimates. By using --ml search-- before --ml maximize-- I get the same estimates. What I want to know is whether it is possible for --ml check-- to show that there are problems with my likelihood evaluator even if there is none. If not, what kind of errors in my programming (or perhaps the data set) may cause this discrepancy? I have not written the program code in this email so as not to clutter it. But please let me know if it is necessary to see the program code in order to be able to provide answers to my questions and I will do so.

I am running Intercooled STATA Version 8 on Windows.

Thanks in advance,
Alita Nandi

*
* For searches and help try:
* http://www.stata.com/support/faqs/res/findit.html
* http://www.stata.com/support/statalist/faq
* http://www.ats.ucla.edu/stat/stata/




© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index