Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: RE: A question about graph


From   "David Harrison" <david.harrison@icnarc.org>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: RE: A question about graph
Date   Tue, 19 Apr 2005 11:28:44 +0100

You are missing a comma before the legend option.

David

-----Original Message-----
From: Ma, Sai [mailto:saima@prgs.edu]
Sent: 19 April 2005 05:13
To: statalist@hsphsun2.harvard.edu
Subject: st: A question about graph


Hi all,

I am trying to generate a twoway scatter graph using STATA 8 but somehow my code doesn't work well.

twoway (scatter y x if sex==1, msymbol(Oh) mlcolor(red) yline(2500) ytitle(Y) xtitle(X))  /*
*/  (scatter y x if sex==2, msymbol(O) mlcolor(blue))  /*
*/  legend(order(1 "Male" 2 "Female"))


There is no problem to just run the first two lines, but every time when I try to run the whole thing, it always returns with ") required". Anybody knows what's going on here? Thanks in advance!

************************************
Sai Ma
Doctoral Fellow
Pardee RAND Graduate School
1776 Main Street,
Santa Monica, CA 90407
Tel: (310) 393-0411 ext. 7612




--------------------

This email message is for the sole use of the intended recipient(s) and
may contain privileged information. Any unauthorized review, use,
disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
of the original message.




*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index