Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: micombine error message: no row identifier


From   <richard.rogersphd@verizon.net>
To   <statalist@hsphsun2.harvard.edu>
Subject   st: micombine error message: no row identifier
Date   Thu, 30 Sep 2004 8:08:21 -0500

Greetings.  I am trying to use micombine, part of the multiple imputation features mentioned recently in 4-3.  When I run the program, I get the following error message:  "no row-identifier variable found -- data may have incorrect format".

Context:  I am using the Federal Reserve Survey of Consumer Finances.  The imputed values are already calculated, and I have a variable that tracks the imputation (number 1 through 5).  The variable is a numeric format, but given the error about formatting, I converted it to integer and string formats, but still no luck.  I am in Stata/SE 8.2.  I have until this point been using the Stata macro from the survey codebook, but micombine gives me more functionality.

I am assuming that there is some simple trick here that I'm missing, or else I completely don't understand this at all.  I looked at the ado file and found where the error message was being generated, but I'm not a real programmer and much of what I saw was beyond my skill set.

Any suggestions would be useful.

Regards,
Rick Rogers
Stata neophyte

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index