Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: Re: st: xtile problems


From   sdriver@stata.com (Shannon Driver, StataCorp)
To   statalist@hsphsun2.harvard.edu
Subject   Re: Re: st: xtile problems
Date   Tue, 03 Feb 2004 14:43:45 -0600

Javier Bacarreza <superpiti@yahoo.com> wrote:

> Thanks for answering,
> The problem is:
> 
> When I write:
> 
> xtile qyh=yhog [w=factor],nq(10)
> 
> The program says:
> 
> (analytic weights assumed)
> invalid syntax
> r(198);
> 
> In stata 7 it used to work fine, but i dont have stata
> 7 anymore only stata 8 and it doesn't work, I really
> appreciate your help.

I have been working with Javier privately on this problem, and I believe we
have figured out what was going wrong.  It seems that Javier's ado-file and
executable updates were out of sync.  After performing a complete update, the
problem was resolved.

There was a command being called by -xtile-, or being called by a command
called by -xtile-, that had been updated to allow different syntax.  In this
case, Javier's ado-files had been updated to use this new syntax, yet his
executable had not been updated to allow the new syntax.  

This is one reason why it is so important that you make sure you have the most
recent ado-file and executable updates.  One may rely on the other, and it is
not a good idea to let them get out of sync.

--Shannon Driver
  sdriver@stata.com

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index