Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

Re: st: Re: Stuck at akdensity


From   philippe.vankerm@ceps.lu
To   statalist@hsphsun2.harvard.edu
Subject   Re: st: Re: Stuck at akdensity
Date   Mon, 15 Dec 2003 10:53:04 +0100

I'm only now reading this thread. Renzo is right. I will send out a 
corrected file later today.

Best wishes

Philippe
(Van Kerm - author of -akdensity-)


>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Re: st: Re: Stuck at akdensity

From
  "Renzo Comolli" <renzo.comolli@yale.edu>
To
  <statalist@hsphsun2.harvard.edu>
Subject
  Re: st: Re: Stuck at akdensity
Date
  Sat, 6 Dec 2003 23:22:42 -0500


Both the problem and the solution seem to be the same as the ones you had
last week with outreg: some compound quotes are missing.

Search inside the ado file you are using (I believe -akdensity-) for the
line that says
                 qui save `tmpsav' , replace
And replace it with
                 qui save `"`tmpsav'"' , replace
Either type -discard- or restart Stata and rerun your program.

If, subsequently, it gets stuck somewhere else, repeat the procedure: find
the line where it gets stuck, add compuond quotes. Then, either type
-discard- or restart Stata and rerun your program.

The reason why you get these errors (is that the origianl code contains a
minor bug) while the other users do not is that your machine is set up in 
a
way such that operations are carried out in folders with blanks in their
path name.
Your machine works in C:\Documents and Settings\user\Local Settings\Temp\
If it were to work in C:\Documents_and_Settings\user\Local_Settings\Temp\ 
or
any other folder with no blanks in the path, the bug would never bother 
you.


Ciao
Renzo


----------------------------------------------------------------------------
----
*From   Ramani Gunatilaka <Ramani.Gunatilaka@buseco.monash.edu.au> 
To   statalist@hsphsun2.harvard.edu 
Subject   st: Re: Stuck at akdensity 
Date   Sun, 07 Dec 2003 01:41:49 +0000 

Hi all,
Stuck again this weekend, I'm afraid. I am trying to plot akdensity
distributions using Philippe Van Kerm's SSC download. 
My programme gets stuck within the akdensity routine, and I can't figure 
out
why. 

This is the log output of set trace on immediately preceding error 
message.

<snip>
       - qui save `tmpsav' , replace
      = qui save C:\Documents and Settings\user\Local
Settings\Temp\ST_0200003t
> .tmp , replace
invalid 'and' 

Would anybody have any ideas re: what's going wrong?
Thanks so much,
Ramani 


*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept for the presence of computer viruses.

**********************************************************************

*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index