Stata The Stata listserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date index][Thread index]

st: XTGLS: missing statistics & XTTEST2 problem


From   "John A Karikari" <KarikariJ@gao.gov>
To   "<"<statalist@hsphsun2.harvard.edu>
Subject   st: XTGLS: missing statistics & XTTEST2 problem
Date   Tue, 09 Dec 2003 12:47:31 -0500

I'm using XTGLS to estimate a panel data of about 280 cities and 360
time periods.  I get a missing value for the log-likelihood, and the
xttest2 indicates that matrix has missing values.  Please see regression
output below.
I'll appreciate any insights, and thanks.

John 


.**************************
. *xtgls
. xtgls pmb_dev h_dev s_dev c_dev, /*
> */ i(city_id) t(edate) panels(c) corr(ar1)

Cross-sectional time-series FGLS regression

Coefficients:  generalized least squares
Panels:        heteroskedastic with cross-sectional correlation
Correlation:   common AR(1) coefficient for all panels  (0.8189)

Estimated covariances      =     39903          Number of obs     
=	101802
Estimated autocorrelations =         1          Number of groups  
=	282
Estimated coefficients     =         4          Time periods      
=	361
Wald chi2(3)       =	4104.11
Log likelihood             =         .          Prob > chi2       
=	0.0000

	
pmb_dev       Coef.   Std. Err.      z    P>z     [95%
Conf.	Interval]
	
h_dev    .0000293   .0000297     0.98   0.325    
-.000029	.0000875
s_dev   -8.364303   .1310437   -63.83   0.000   
-8.621144	-8.107463
c_dev    .1018725   .0359491     2.83   0.005    
.0314136	.1723313
_cons   -.0083858   .2799171    -0.03   0.976   
-.5570133	.5402417
	

. xttest2
matrix has missing values
r(504);

end of do-file
r(504);

*******************
*
*   For searches and help try:
*   http://www.stata.com/support/faqs/res/findit.html
*   http://www.stata.com/support/statalist/faq
*   http://www.ats.ucla.edu/stat/stata/



© Copyright 1996–2014 StataCorp LP   |   Terms of use   |   Privacy   |   Contact us   |   What's new   |   Site index